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Low-Cost FPGAs
− Cyclone II & Cyclone

Embedded Processor Solutions
− Nios II

Configuration Devices
− Serial (EPCS) & Enhanced (EPC)

Programmable Logic FamiliesProgrammable Logic Families
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What is Nios II?What is Nios II?
Altera’s Second Generation Soft-Core 32 Bit RISC Microprocessor
− Developed Internally By Altera
− Harvard Architecture
− Royalty-Free

FPGA

- Nios II Plus All Peripherals Written In HDL
- Can Be Targeted For All Altera FPGAs
- Synthesis Using Quartus II Integrated Synthesis
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Nios II Processor ArchitectureNios II Processor Architecture
Classic Pipelined RISC Machine
− 32 General Purpose Registers
− 3 Instruction Formats 
− 32-Bit Instructions
− 32-Bit Data Path
− Flat Register File
− Separate Instruction and Data Cache (configurable sizes)
− Tightly-Coupled Memory Options
− Branch Prediction
− 32 Prioritized Interrupts
− On-Chip Hardware (Multiply, Shift, Rotate)
− Custom Instructions
− JTAG-Based Hardware Debug Unit
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Problem:  Reduce Cost, Complexity & 
Power
Problem:  Reduce Cost, Complexity & 
Power

Flash

SDRAM

CPU

DSP

I/O
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I/O FPGA

I/O I/O I/O

CPU DSP

Solution: Replace External Devices 
with Programmable Logic

FPGA
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Problem:  Reduce Cost, Complexity & 
Power
Problem:  Reduce Cost, Complexity & 
Power

Flash

SDRAM

Solution: Replace External Devices 
with Programmable Logic

CPU is a Critical Control Function 
Required for System-Level Integration

System On A Programmable Chip (SOPC)

FPGA
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LicensingLicensing
Nios II Delivered As Encrypted Megacore
− Licensed Via Feature Line In Existing Quartus II License File
− Consistent With General Altera Megacore Delivery Mechanism
− Enables Detection Of Nios II In Customer Designs (Talkback)

No Nios II Feature Line (OpenCore Plus Mode)
− System Runs If Tethered To Host PC
− System Times Out If Disconnected from PC After ~ 1 hr

Nios II Feature Line (Active Subscriber)
− Subscription and New Dev Kit Customers Obtain Licenses From 

www.altera.com
− Nios II CPU RTL Remains Encrypted

Nios II Source License
− Available Upon Request On Case-By-Case Basis
− Included With Purchase Of Nios II ASIC License
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Software & Development ToolsSoftware & Development Tools
Quartus II
− All Stratix, Cyclone & Hardcopy Devices
− APEX II, APEX 20K/E/C, Excalibur, & 

Mercury Devices
− FLEX 10K/A/E, ACEX 1K, FLEX 6000 

Devices
− MAX II,  MAX 7000S/AE/B, MAX 3000A 

Devices
Quartus II Web Edition
− Free Version 
− Not All Features & Devices Included

See www.altera.com for Feature 
Comparison
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Quartus II Development SystemQuartus II Development System
Fully-Integrated Design Tool
− Multiple Design Entry Methods
− Logic Synthesis
− Place & Route
− Simulation
− Timing & Power Analysis
− Device Programming
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Typical PLD Design Flow

Synthesis
- Translate Design into Device Specific Primitives
- Optimization to Meet Required Area & Performance Constraints
- Precision Synthesis, Synplify/Synplify Pro, Design Compiler FPGA, 

Quartus II

Design Specification

Place & Route
- Map Primitives to Specific Locations inside
Target Technology with Reference to Area &
Performance Constraints

- Specify Routing Resources to Be Used

Design Entry/RTL Coding
- Behavioral or Structural Description of Design

RTL Simulation
- Functional Simulation (Modelsim®, Quartus II)
- Verify Logic Model & Data Flow 

(No Timing Delays)

LE M512

M4K I/O
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Typical PLD Design Flow
Timing Analysis

- Verify Performance Specifications Were Met
- Static Timing Analysis

Gate Level Simulation
- Timing Simulation
- Verify Design Will Work in Target Technology

PC Board Simulation & Test
- Simulate Board Design
- Program & Test Device on Board
- Use SignalTap II for Debugging

tclk
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Design Entry MethodsDesign Entry Methods
Quartus II
− Text Editor

AHDL
VHDL
Verilog

− Schematic Editor
Block Diagram File
Graphic Design File

− Memory Editor
HEX
MIF

3rd-Party EDA Tools
− EDIF
− HDL
− VQM

Mixing & Matching Design Files Allowed

Top-level design files can 
be schematic, HDL or 3rd-
Party Netlist File

Block
File

Symbol
File

Text
File

Text
File

Text
File

Imported from 3rd-Party 
EDA toolsGenerated within Quartus II

Text
File

Text
File

.v, vlg,
.vhd, .vhdl, 

vqm

.edf
.edif

.v.vhd.tdf.bsf.bdf
.gdf

Top-
Level 
File
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Objectives Objectives 
Create a project using the New Project 
Wizard
Name the project
Add design files
Pick a device
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Step 1 (Setup Project for QII5_1) Step 1 (Setup Project for QII5_1) 
Under File, Select New Project Wizard…. 
A new window appears.  If an Introduction 
screen appears, click Next.
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Step 2 (Setup Project for QII5_1)Step 2 (Setup Project for QII5_1)
Page 1 of the wizard should be completed with the following 

working directory for this project <lab_install_directory> \Dsp_7_segment\

name of project Dsp_7_segment

top-level design entity Dsp_7_segment

Copy “state_machine.v” and past in
Dsp_7_segment

Click Next to advance to the 
Project Wizard: Add Files [page 2 of 5].
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Step 3 (Setup Project for QII5_1)Step 3 (Setup Project for QII5_1)
Using the browse button, select state_machine.v
Add to the project.  Click Next.
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Step 4 (Setup Project for QII5_1)Step 4 (Setup Project for QII5_1)
On page 3, select Stratix as the Family.  Also, in the Filters section,
set Package to FBFA, Pin count to 780, and Speed grade to 5. 
Select the EP1S25F780C5 device from 
the Available devices: window. Click Next.
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Step 5 (Setup Project for QII5_1)Step 5 (Setup Project for QII5_1)
On page 4 , you can specify any third party EDA tools you may be using 
along with Quartus II.  Since these exercises will be done entirely within 
Quartus II, click Next.
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Step 6 (Setup Project for QII5_1)Step 6 (Setup Project for QII5_1)
The summary screen appears as shown. Click Finish. 
The project is now created.
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Objectives Objectives 
Create a counter using the MegaWizard 
Plug-in Manager
Build a design using the schematic editor
Analyze and elaborate the design to check 
for errors
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Step 1 Create schematic fileStep 1 Create schematic file
Select File ⇒ New and select Block Diagram/Schematic File.  Click OK.
Select File ⇒ Save As and save the file as

<lab_install_directory> \Dsp_7_segment\ Dsp_7_segment.bdf
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Step 2 Build an 23 bits counter using the MegaWizard Plug-in ManagerStep 2 Build an 23 bits counter using the MegaWizard Plug-in Manager

1.Choose Tools ⇒ MegaWizard Plug-In Manager. In the window that appears, 
select Create a new custom megafunction variation.  Click on Next.

2.On page 2a of the MegaWizard expand the arithmetic folder and select
LPM_COUNTER.

3.Choose Verilog HDL output For the name of the output file, type timer_1s. 
Click on Next
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Step 3Step 3
1. Set the output bus to 27 bits. For the remaining settings in this window, 

use the defaults that appear ..  Select next
2. .Turn on “Modulus , with a count modulus of “and key in 79999999
3. Select finish
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Step 4Step 4
In the Graphic Editor, double-click in the screen so that the Symbol Window
appears.  Inside the symbol window, click on      to expand the symbols defined 
in the Project folder.  Double-click on timer_1s. Click the 
left mouse button to put down the symbol inside the schematic file.. The symbol
for “timer_1s” now appears in the schematic.
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Step 5Step 5
1. From the File menu, open the file state_machine.v
2. From the File menu, go the Create/Update menu option and select

Create Symbol Files for Current File.  Click Yes to save changes
to Dsp_7_segment.bdf.

3. Once Quartus II is finished creating the symbol, click OK.  Close the
state_machine.v file 

4. In the Graphic Editor, double-click in the screen so that the Symbol
Window appears again.  Double-click on state_machine in the 
Project folder. Click OK... The symbol for state_machine now 
appears in the schematic.
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Step 6 Add Pins to the Design Step 6 Add Pins to the Design 
Input Output

sys_clk 7_out[6..0]

reset Dig1

For each of the pins listed in left Table , you must insert
a pin and change its name 

1. To place pins in the schematic file, go to Edit ⇒ Insert ⇒ Symbol OR
double-click in any empty location of the Graphic Editor. 

2. Browse to libraries ⇒ primitives ⇒ pin folder.  Double-click on input
or output Hint:  To insert multiple pins select Repeat Insert Mode.

3. To rename the pins double-click on the pin name after it has been
inserted.

4. Type the name in the Pin name(s) field and Click OK
.
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Step 7 Connect the Pins and Blocks in the SchematicStep 7 Connect the Pins and Blocks in the Schematic

1. In the left hand tool bar click on       button to draw a wire and       button to draw a bus.  
Another way to draw wires and busses is to place the cursor next to the port of any 
symbol.  When you do this, the wire or bus tool will automatically appear.

2. Connect all of the pins and blocks as shown in the figure below
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Step 8 Save and check the schematic Step 8 Save and check the schematic 
1. Click on the Save button in the toolbar      to save the schematic. 
2. From the Project menu, select Add/Remove Files in Project.  

Click on the browse button to make sure the Dsp_7_segment.bdf, 
timer_1s and state_machine are added  to the project.

3. From the Processing menu, select Start ⇒ Start Analysis & Elaboration. 

Analysis and elaboration checks that all the design files are present and
connections have been made correctly.

4. Click OK when analysis and elaboration is completed
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Objectives Objectives 
Pin assignment
Perform full compilation Build a design 
using the schematic editor
How to Download programming file 
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Step 1Step 1
1. Choose Assignments ⇒ Assignment editor.
2. From the View menu, select Show All Know Pin Names.
3. Please click Pin in Category
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Step 2Step 2
1. Pls install DSP Development Kit  Stratix edtion CD
2. Open ds_stratix_dsp_bd.pdf from C:\megacore\stratix_dsp_kit-v1.1.0\Doc
3. Check clk , pushbotton and seven segment display pin location from 

ds_stratix_dsp_bd.pdf 
4. Key your pin number in location
5. Click on the Save button in the toolbar 
6. From Assignments, select Device. Click Device & Pin options. Click

Unused pins .Select As input tri-stated from Reserve all unused pins
7. From the Processing menu, select Start Compilation 
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Step 3Step 3
1. From the Tools menu, select programmer
2. Click on Add File. Select Dsp_7_segment.sof.
3. Check Hardware Setup. Select your download cable on 

Currently selected hardware(ByteBlasterII)
4. Select JTAG from Mode
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Step 4Step 4
1. Turn on Program/configure. Or see figure below
2. Click Start
3. See 7-segment status
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Thank YouThank You




